package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d{0,3}|1\d{4}|20000)$`)
var str = `50001
10000
1
10
100
1000
10000
19999
20000
20001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}