$re = '/^([1-9]\d{0,3}|1\d{4}|20000)$/m';
$str = '50001
10000
1
10
100
1000
10000
19999
20000
20001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);