import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d{0,3}|1\\d{4}|20000)$";
final String string = "50001\n"
+ "10000\n"
+ "1\n"
+ "10\n"
+ "100\n"
+ "1000\n"
+ "10000\n"
+ "19999\n"
+ "20000\n"
+ "20001";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}