#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9@!#\/$%&'*+=?^_`{|}~.-]+$"
Local $sString = "thisIsAValidString" & @CRLF & _
"but this not because have spaces" & @CRLF & _
"th1s0n3IsV4l1dToo" & @CRLF & _
"andAnother!WithNumb3r&Symbols!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")