import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9@!#\\/$%&'*+=?^_`\\{|\\}~.-]+$";
final String string = "thisIsAValidString\n"
+ "but this not because have spaces\n"
+ "th1s0n3IsV4l1dToo\n"
+ "andAnother!WithNumb3r&Symbols!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}