$re = '/^[a-z0-9@!#\/$%&\'*+=?^_`{|}~.-]+$/mi';
$str = 'thisIsAValidString
but this not because have spaces
th1s0n3IsV4l1dToo
andAnother!WithNumb3r&Symbols!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);