const regex = /^[a-z0-9@!#\/$%&'*+=?^_`{|}~.-]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9@!#\\\/$%&\'*+=?^_`{|}~.-]+$', 'gmi')
const str = `thisIsAValidString
but this not because have spaces
th1s0n3IsV4l1dToo
andAnother!WithNumb3r&Symbols!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}