package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z0-9@!#\/$%&'*+=?^_`{|}~.-]+$`)
var str = `thisIsAValidString
but this not because have spaces
th1s0n3IsV4l1dToo
andAnother!WithNumb3r&Symbols!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}