using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{15}(?:[a-z0-9]{3})?$";
string input = @"001i000001AWbWuGTA
001i000001AWbWugta
50130000000014c
50130000000014C
50130000000014ca
50130000000014cab
50130000000014cabde";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}