re = /^[a-z0-9]{15}(?:[a-z0-9]{3})?$/mi
str = '001i000001AWbWuGTA
001i000001AWbWugta
50130000000014c
50130000000014C
50130000000014ca
50130000000014cab
50130000000014cabde'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end