import re
regex = re.compile(r"^[a-z0-9]{15}(?:[a-z0-9]{3})?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("001i000001AWbWuGTA\n"
"001i000001AWbWugta\n"
"50130000000014c\n"
"50130000000014C\n"
"50130000000014ca\n"
"50130000000014cab\n"
"50130000000014cabde")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")