import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{15}(?:[a-z0-9]{3})?$";
final String string = "001i000001AWbWuGTA\n"
+ "001i000001AWbWugta\n"
+ "50130000000014c\n"
+ "50130000000014C\n"
+ "50130000000014ca\n"
+ "50130000000014cab\n"
+ "50130000000014cabde";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}