use strict;
my $str = '001i000001AWbWuGTA
001i000001AWbWugta
50130000000014c
50130000000014C
50130000000014ca
50130000000014cab
50130000000014cabde';
my $regex = qr/^[a-z0-9]{15}(?:[a-z0-9]{3})?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}