#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(panel|api)(/|\?|$)"
Local $sString = "/panel" & @CRLF & _
"/panel/test" & @CRLF & _
"/panel?test" & @CRLF & _
"/panelpage" & @CRLF & _
"/panel-page" & @CRLF & _
"/panel24" & @CRLF & _
"/blog/panel"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")