re = /^\/(panel|api)(\/|\?|$)/m
str = '/panel
/panel/test
/panel?test
/panelpage
/panel-page
/panel24
/blog/panel'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end