import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/(panel|api)(/|\\?|$)";
final String string = "/panel\n"
+ "/panel/test\n"
+ "/panel?test\n"
+ "/panelpage\n"
+ "/panel-page\n"
+ "/panel24\n"
+ "/blog/panel";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}