package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(panel|api)(/|\?|$)`)
var str = `/panel
/panel/test
/panel?test
/panelpage
/panel-page
/panel24
/blog/panel`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}