# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\d:]*)\s*GMT/$1/im;t' <<< "located on 10/6/2015 5:18:14 GMT"