const regex = /([\d:]*)\s*GMT/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d:]*)\\s*GMT', 'im')
const str = `located on 10/6/2015 5:18:14 GMT`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);