$re = '/([\d:]*)\s*GMT/im';
$str = 'located on 10/6/2015 5:18:14 GMT';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;