re = /([\d:]*)\s*GMT/im
str = 'located on 10/6/2015 5:18:14 GMT'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result