use strict;
my $str = 'located on 10/6/2015 5:18:14 GMT';
my $regex = qr/([\d:]*)\s*GMT/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";