use strict;
my $str = 'TargetUPS: (java.lang.Integer) "200"
TargetFPS: (java.lang.Integer) "60"
DebugID: (java.lang.Character) "s"
MainCamera: (game.gameObject.graphics.Camera) {
(java.awt.geom.Rectangle2D.Float) {
(java.lang.Integer)"0"
(java.lang.Integer)"0"
(java.lang.Integer)"800"
(java.lang.Integer)"600")
},
(game.screen.ScreenRect) {
(java.lang.Integer)"0"
(java.lang.Integer)"0"
(java.lang.Integer)"1"
(java.lang.Integer)"1"
},
(java.awt.Color) {
(java.lang.Integer)"0"
(java.lang.Integer)"255"
(java.lang.Integer)"0"
}
}';
my $regex = qr/([a-zA-Z0-9]*):\s*\(([a-zA-Z0-9.]*)\)\s*\{(.*?)\}/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}