// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)([a-zA-Z0-9]*):\s*\(([a-zA-Z0-9.]*)\)\s*\{(.*?)\}").unwrap();
let string = "TargetUPS: (java.lang.Integer) \"200\"
TargetFPS: (java.lang.Integer) \"60\"
DebugID: (java.lang.Character) \"s\"
MainCamera: (game.gameObject.graphics.Camera) {
(java.awt.geom.Rectangle2D.Float) {
(java.lang.Integer)\"0\"
(java.lang.Integer)\"0\"
(java.lang.Integer)\"800\"
(java.lang.Integer)\"600\")
},
(game.screen.ScreenRect) {
(java.lang.Integer)\"0\"
(java.lang.Integer)\"0\"
(java.lang.Integer)\"1\"
(java.lang.Integer)\"1\"
},
(java.awt.Color) {
(java.lang.Integer)\"0\"
(java.lang.Integer)\"255\"
(java.lang.Integer)\"0\"
}
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}