$re = '/([a-zA-Z0-9]*):\s*\(([a-zA-Z0-9.]*)\)\s*\{(.*?)\}/s';
$str = 'TargetUPS: (java.lang.Integer) "200"
TargetFPS: (java.lang.Integer) "60"
DebugID: (java.lang.Character) "s"
MainCamera: (game.gameObject.graphics.Camera) {
(java.awt.geom.Rectangle2D.Float) {
(java.lang.Integer)"0"
(java.lang.Integer)"0"
(java.lang.Integer)"800"
(java.lang.Integer)"600")
},
(game.screen.ScreenRect) {
(java.lang.Integer)"0"
(java.lang.Integer)"0"
(java.lang.Integer)"1"
(java.lang.Integer)"1"
},
(java.awt.Color) {
(java.lang.Integer)"0"
(java.lang.Integer)"255"
(java.lang.Integer)"0"
}
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);