import re
regex = re.compile(r"([a-zA-Z0-9]*):\s*\(([a-zA-Z0-9.]*)\)\s*\{(.*?)\}", flags=re.DOTALL)
test_str = ("TargetUPS: (java.lang.Integer) \"200\"\n"
"TargetFPS: (java.lang.Integer) \"60\"\n"
"DebugID: (java.lang.Character) \"s\"\n"
"MainCamera: (game.gameObject.graphics.Camera) {\n"
" (java.awt.geom.Rectangle2D.Float) {\n"
" (java.lang.Integer)\"0\"\n"
" (java.lang.Integer)\"0\"\n"
" (java.lang.Integer)\"800\"\n"
" (java.lang.Integer)\"600\")\n"
" },\n"
" (game.screen.ScreenRect) {\n"
" (java.lang.Integer)\"0\"\n"
" (java.lang.Integer)\"0\"\n"
" (java.lang.Integer)\"1\"\n"
" (java.lang.Integer)\"1\"\n"
" }, \n"
" (java.awt.Color) {\n"
" (java.lang.Integer)\"0\"\n"
" (java.lang.Integer)\"255\"\n"
" (java.lang.Integer)\"0\"\n"
" }\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")