#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z.'"#]+$"
Local $sString = "This.is.the.first#....valid...l'i'n'e" & @CRLF & _
"Jonh's.valid.string" & @CRLF & _
"" & @CRLF & _
"this is not valid" & @CRLF & _
"another1nv4l1d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")