$re = '/^[a-z.\'"#]+$/mi';
$str = 'This.is.the.first#....valid...l\'i\'n\'e
Jonh\'s.valid.string
this is not valid
another1nv4l1d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);