re = /^[a-z.'"#]+$/mi
str = 'This.is.the.first#....valid...l\'i\'n\'e
Jonh\'s.valid.string
this is not valid
another1nv4l1d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end