package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z.'"#]+$`)
var str = `This.is.the.first#....valid...l'i'n'e
Jonh's.valid.string
this is not valid
another1nv4l1d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}