// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?mi)^[a-z.'"#]+$"##).unwrap();
let string = "This.is.the.first#....valid...l'i'n'e
Jonh's.valid.string
this is not valid
another1nv4l1d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}