package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/.+pepper.com\/(deals|vouchers)).?-([[:digit:]])`)
var str = `https://beta4.pepper.com/deals/kettler-cross-m-crosstrainer-voor-eur28895-wehkamp-17634`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}