$re = '/(https?:\/\/.+pepper.com\/(deals|vouchers)).?-([[:digit:]])/';
$str = 'https://beta4.pepper.com/deals/kettler-cross-m-crosstrainer-voor-eur28895-wehkamp-17634';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);