const regex = /(https?:\/\/.+pepper.com\/(deals|vouchers)).?-([[:digit:]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/.+pepper.com\\\/(deals|vouchers)).?-([[:digit:]])', 'g')
const str = `https://beta4.pepper.com/deals/kettler-cross-m-crosstrainer-voor-eur28895-wehkamp-17634`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}