re = /(https?:\/\/.+pepper.com\/(deals|vouchers)).?-([[:digit:]])/
str = 'https://beta4.pepper.com/deals/kettler-cross-m-crosstrainer-voor-eur28895-wehkamp-17634'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end