// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/.+pepper.com\/(deals|vouchers)).?-([[:digit:]])").unwrap();
let string = "https://beta4.pepper.com/deals/kettler-cross-m-crosstrainer-voor-eur28895-wehkamp-17634";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}