using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ =\[\]]+)(?:\[(\d+)\](?:\[(\w)\])?)?(?:=((?:"".*?"")|(?:[^ ]+)))?";
string input = @"foo.csv foo=bar bang=""this is a test"" filter[1]=""molf"" filter[2][r]=""gnarf dd""
http://bla.com/foo.png foo=bar bang=""this is a test"" filter[1]=""molf"" filter[2][r]=""gnarf dd""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}