re = /([^ =\[\]]+)(?:\[(\d+)\](?:\[(\w)\])?)?(?:=((?:".*?")|(?:[^ ]+)))?/
str = 'foo.csv foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"
http://bla.com/foo.png foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end