use strict;
my $str = 'foo.csv foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"
http://bla.com/foo.png foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"';
my $regex = qr/([^ =\[\]]+)(?:\[(\d+)\](?:\[(\w)\])?)?(?:=((?:".*?")|(?:[^ ]+)))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}