// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([^ =\[\]]+)(?:\[(\d+)\](?:\[(\w)\])?)?(?:=((?:".*?")|(?:[^ ]+)))?"#).unwrap();
let string = "foo.csv foo=bar bang=\"this is a test\" filter[1]=\"molf\" filter[2][r]=\"gnarf dd\"
http://bla.com/foo.png foo=bar bang=\"this is a test\" filter[1]=\"molf\" filter[2][r]=\"gnarf dd\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}