package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[([^][]+)\](\(((?:[^()]+)+)\)))`)
var str = `abc def [Mylink](https://link-url-here.org) 123 [anotherLink](http://dot.com)
xyz 123 [Mylink2](another_page.md)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}