// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[([^][]+)\](\(((?:[^()]+)+)\)))").unwrap();
let string = "abc def [Mylink](https://link-url-here.org) 123 [anotherLink](http://dot.com)
xyz 123 [Mylink2](another_page.md)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}