import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[([^][]+)\\](\\(((?:[^()]+)+)\\)))";
final String string = "abc def [Mylink](https://link-url-here.org) 123 [anotherLink](http://dot.com)\n"
+ "xyz 123 [Mylink2](another_page.md)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}