re = /(\[([^][]+)\](\(((?:[^()]+)+)\)))/m
str = 'abc def [Mylink](https://link-url-here.org) 123 [anotherLink](http://dot.com)
xyz 123 [Mylink2](another_page.md)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end