import re
regex = re.compile(r"(\[([^][]+)\](\(((?:[^()]+)+)\)))", flags=re.MULTILINE)
test_str = ("abc def [Mylink](https://link-url-here.org) 123 [anotherLink](http://dot.com)\n"
"xyz 123 [Mylink2](another_page.md)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")