#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?)\.((25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?|[0-9])\.){2}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?):3306$"
Local $sString = "1.0.0.1:3306" & @CRLF & _
"8.10.222.34:3306" & @CRLF & _
"254.254.254.254:3306"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")