package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?)\.((25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?|[0-9])\.){2}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?):3306$`)
var str = `1.0.0.1:3306
8.10.222.34:3306
254.254.254.254:3306`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}