import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?)\\.((25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?|[0-9])\\.){2}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?):3306$";
final String string = "1.0.0.1:3306\n"
+ "8.10.222.34:3306\n"
+ "254.254.254.254:3306";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}