re = /(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?)\.((25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?|[0-9])\.){2}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?):3306$/m
str = '1.0.0.1:3306
8.10.222.34:3306
254.254.254.254:3306'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end