// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?)\.((25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?|[0-9])\.){2}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]?):3306$").unwrap();
let string = "1.0.0.1:3306
8.10.222.34:3306
254.254.254.254:3306";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}